Mikrotik Bridge VLAN Tagging

Pada dasarnya Bridge digunakan untuk menghubungkan 2 segmen LAN menggunakan Router. Jadi dua segmen LAN ini akan disatukan menjadi satu collision domain dengan menggunakan Router.

Pada gambar diatas, jika kita hanya memiliki Router, maka pada Router tersebut kita buat Bridge=bridge1, dimana anggota port nya adalah eth0, eth1, dan eth2. Dengan demikian maka eth0, eth1, eth2 yang merupakan access port sudah dalam satu collision domain.

Agak berbeda dengan Switch. Dimana kalau dalam switch maka ketiga segmen ini tinggal dimasukkan dalam tiga port access, dimana ketiga port access ini dalam VLAN yang sama.

VLAN TAGGING

Vlant tagging adalah implementasi dari protokol 802.1q (dot1q). Dimana paket Ethernet akan diberikan tag.

Satu port dalam switch atau bridge, dapat diset apakah berupa trunk atau access. Jika trunk, maka paket-paket yang lewat harus ada Vlan Tagging 802.1q nya.

Berikut contoh dari VLAN Tagging.

L3-Switch sebenarnya adalah Mikrotik Router (Cloud Hosted Router 6.41.4).

Skenario nya adalah sbb:

  • ether4 digunakan untuk komunikasi ke dunia luar (Winbox)
  • ether1, digunakan sebagai trunk port ke arah R1 melewatkan Vlan20 dan Vlan30 (tagged)
  • ether2, digunakan sebagai access port ke arah PC2 (Vlan20 untagged)
  • ether3, digunakan sebagai access port ke arah PC1 (Vlan30 untagged)

LANGKAH-LANGKAH SETTING

port eth4 dipakai untuk akses Winbox:
/ip address add address=192.168.48.99/24 interface=ether4

1. Buat Bridge dan Daftarkan Port yang tergabung

/interface bridge
add name=bridge1

/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2 pvid=20
add bridge=bridge1 interface=ether3 pvid=30

arti perintah (rule ingress)
add bridge=bridge1 interface=ether2 pvid=20
adalah bahwa: interface ether2 adalah bagian dari collision domain bridge1 dan juga member dari pivd 20 (port vlan id). Jadi jika ada paket masuk (ingress) ke ether2, dan harus di lempar ke ether1 (trunk) maka harus di tag dengan id 20.

Terlihat pada gambar diatas ether1, ether2, ether3 member dari brigde1. Artinya ke tiga port tersebut sudah berada dalam satu collision domain.

Selanjutnya barulah kita buat Rules, kapan paket akan di tagged, kapan di untagged.

2. Set VLAN Filtering Rules

/interface bridge vlan
add bridge=bridge1 tagged=ether1 untagged=ether2 vlan-ids=20
add bridge=bridge1 tagged=ether1 untagged=ehter3 vlan-ids=30

arti perintah (rule egress)
add bridge=bridge1 tagged=ether1 untagged=ether2 vlan-ids=20
adalah bahwa: jika ada paket dengan tag 20, dan keluar di ether1, maka dia biarkan tagged. Namun apabila keluar dari ether2 maka jadikan dia untagged.

3. Aktifkan VLAN Filtering Rules

/interface bridge set bridge1 vlan-filtering=yes

Selesai configure Mikrotik.

Jangan lupa di R1 (Cisco3600) aktifkan di eth0/1.0 dan eth0/0.2 ip address nya.

R1> config terminal

interface eth0/0.1
encap dot1q
ip address 10.30.0.254 255.255.255.0  30

interface eth0/0.2
encap dot1q
ip address 10.20.0.254 255.255.255.0  30

interface eth0/0
no shut

Selanjutnya dari PC2 sudab bisa PING ke PC1

Catatan:

Perhatikan bahwa kita tidak mencreate interface VLAN secara khusus. Sedangkan VLAN20 dan VLAN30 diatas adalah VLAN berdasarkan port (port based VLAN).

 

Cara lain untuk solusi diatas dengan mencreate VLAN20 dan VLAN30.

/interface vlan add name=vlan20 interface=ether1

/interface bridge add name=bridge1
/interface bridge port add interface=ether2 bridge=bridge1
/interface bridge port add interface=vlan20 bridge=bridge1

 

Source :

https://multimedia-howto.blogspot.com/2019/03/mikrotik-bridge-vlan-tagging.html