MikroTik – Script pengamanan Protected-Routerboot

Systems –> Scheduler –> Add [+] –> Copas Script dibawah
#####################################
#
#  --[ANTI PROTECTED-ROUTERBOOT]--
#
#####################################
# Set Local String
:local logprotectedrouterboot;
:local logreformatholdbutton;
:local logreformatholdbuttonmax;

# Set local Input
:set logprotectedrouterboot "$[/system routerboard setting get protected-routerboot]"
:set logreformatholdbutton "$[/system routerboard setting get reformat-hold-button]"
:set logreformatholdbuttonmax "$[/system routerboard setting get reformat-hold-button-max]"

# Cek jika Bootloader diubah ke Enable
:if ($logprotectedrouterboot ="enabled") do={

# Set info reformat hold button di Identity di winbox untuk jaga-jaga
/system identity set name="ROUTERBOOT > Min:$logreformatholdbutton - Max:$logreformatholdbuttonmax"

# Kembalikan BootLoader Kepengaturan Awal
/system routerboard setting set protected-routerboot disabled
/system routerboard setting set reformat-hold-button=20s
/system routerboard setting set reformat-hold-button-max=10m

# tahan 5 detik
:delay 5s

# Shutdown mikrotik atau bisa gunakan /system shutdown
/system reboot
}